Gestion des Heures Négatives dans Microsoft Excel : Un Guide Complet

La gestion des heures négatives dans Microsoft Excel est essentielle pour suivre avec précision le temps de travail, surtout dans des situations où les employés peuvent accumuler des heures de congé ou avoir des retards. Excel offre des fonctionnalités puissantes pour manipuler ces heures de manière efficace. Dans cet article, nous explorerons en détail comment gérer les heures négatives dans Excel.

  1. Comprendre le Format des Heures dans Excel :

Avant de plonger dans la gestion des heures négatives, il est crucial de comprendre comment Excel traite les heures. Les heures sont généralement représentées par des valeurs décimales, où une journée complète est équivalente à 1. Par exemple, une demi-journée serait représentée par 0,5.

  1. Formater les Cellules pour les Heures :

Assurez-vous que les cellules où vous allez entrer vos heures sont correctement formatées. Cliquez avec le bouton droit sur les cellules, sélectionnez « Format de cellule » et choisissez le format « Heure ». Cela garantit que vos données sont interprétées comme des heures.

  1. Entrer des Heures Négatives :

Pour entrer des heures négatives, utilisez le signe moins (-) avant la valeur de l’heure. Par exemple, pour représenter une perte de temps de 30 minutes, saisissez « -0:30 ». Excel interprétera cela comme une déduction de temps.

  1. Calculs avec des Heures Négatives :

Les formules d’Excel sont capables de gérer les heures négatives sans problème. Vous pouvez effectuer des calculs tels que l’addition et la soustraction avec des cellules contenant des heures négatives, ce qui permet de suivre facilement les soldes d’heures de travail.

  1. Utilisation de la Fonction CONDITION.SI :

La fonction CONDITION.SI est utile pour appliquer des conditions en fonction du solde d’heures. Par exemple, vous pouvez utiliser la fonction CONDITION.SI pour mettre en surbrillance en rouge les cellules où le solde est négatif, indiquant des heures impayées.

 

 

 

  1. Affichage Personnalisé :

Pour une meilleure lisibilité, personnalisez l’affichage des cellules. Utilisez le format personnalisé pour inclure des libellés spécifiques aux heures négatives, tels que « Retard » ou « Heures impayées ».

  1. Utilisation de la Fonction SOMME.HEURES :

La fonction SOMME.HEURES est pratique pour additionner des heures, même si elles sont négatives. Cela vous permet de calculer facilement le solde total des heures travaillées.

 

 

 

  1. Graphiques et Rapports :

Utilisez des graphiques et des rapports pour visualiser les tendances dans les heures travaillées. Excel propose des outils graphiques qui peuvent rendre plus facile la compréhension des données, y compris les heures négatives.

Conclusion :

La gestion des heures négatives dans Microsoft Excel peut être réalisée de manière simple et efficace en comprenant les concepts fondamentaux des heures dans ce logiciel. En utilisant des formats adaptés, des formules et des fonctions spécifiques, les professionnels peuvent suivre avec précision le temps de travail et les soldes d’heures, facilitant ainsi la gestion du personnel et la conformité aux politiques d’entreprise. Avec ces compétences, Excel devient un outil puissant pour la gestion du temps dans divers contextes professionnels.

Les Fonctions STXT CHERCHE TROUVE

La fonction STXT est une fonction Excel en français qui permet d’extraire un certain nombre de caractères à partir d’une cellule de texte donnée. Elle est souvent utilisée en conjonction avec les fonctions CHERCHE et TROUVE pour rechercher la position d’un certain caractère dans le texte. Voici comment ces trois fonctions fonctionnent ensemble :

1. **TROUVE(texte_cherché, texte, [numéro_départ]) :** Cette fonction recherche le texte_cherché dans le texte spécifié et renvoie la position du premier caractère de texte_cherché dans le texte. Le paramètre optionnel numéro_départ vous permet de spécifier à partir de quel caractère la recherche doit commencer. Si le texte_cherché n’est pas trouvé, la fonction renverra une erreur #VALEUR!.

2. **CHERCHE(texte_cherché, texte, [numéro_départ]) :** C’est une fonction similaire à TROUVE, mais elle est insensible à la casse, ce qui signifie qu’elle ne tient pas compte de la différence entre majuscules et minuscules. Elle renverra également la position du premier caractère du texte_cherché dans le texte. Si le texte_cherché n’est pas trouvé, la fonction renverra une erreur #VALEUR!.

3. **STXT(texte, position_départ, nombre_caractères) :** La fonction STXT prend le texte d’origine et extrait une portion de ce texte, en utilisant la position de départ et le nombre de caractères spécifiés. Vous pouvez utiliser la valeur renvoyée par TROUVE ou CHERCHE comme argument pour la position de départ. Par exemple, si vous voulez extraire un certain texte après le mot « Recherche » dans une cellule A1, vous pouvez utiliser la formule suivante : `=STXT(A1, TROUVE(« Recherche », A1) + LEN(« Recherche »), nombre_de_caractères)`. Cela extraira le texte après le mot « Recherche » dans la cellule A1.

Voici un exemple concret : supposons que vous ayez le texte « Excel est un tableur puissant » dans la cellule A1. Vous voulez extraire le mot « tableur » de ce texte. Vous pouvez utiliser les fonctions comme suit :

`=STXT(A1, TROUVE(« tableur », A1), LEN(« tableur »))`

Cela renverra « tableur », car il recherche d’abord la position de « tableur » dans la cellule A1 avec la fonction TROUVE, puis utilise cette position comme point de départ pour la fonction STXT avec la longueur du mot « tableur » (nombre_de_caractères).

Les Suppression de lignes.

Commençons par les bases, La Suppression simple, d’une ou plusieurs lignes.

Une feuille de calcul EExcel contient 1048576 lignes, cette plage ne peut pas être modifiée.

Dans un Premier temps on contrôle le nombre de lignes existantes dans ma feuille de calcu

 

l, pour cela, on se positionne en A31, puis Ctrl + Majuscule, (en bas à gauche de votre clavier) + flèche directionnelle du bas, ce qui me déplace directement sur la dernière cellule de ma feuille. Pour remonter on se positionne sur la dernière cellule, puis Ctrl + Majuscule (en bas à gauche de votre clavier) + Flèche directionnel du haut.

Pour commencer !

Positionnez le curseur sur le numéro de la ligne concernée à gauche de votre écran, puis un clic gauche pour sélectionner la ligne entière, puis appuyez sur supprimer, ou clic droit de votre souris et sélectionnez supprimer.

Cette action est définitive, en cas d’erreur vous pouvez annuler cette action en appuyant sur Ctrl + Z.

Je vous donne un exemple :

Dans la feuille Exemple de suppression de lignes, les trente premières lignes des colonnes de A à S, sont numérotées de 1 à 30.

Premier exemple je supprime la première ligne :

Clic gauche sur, 1 qui correspond au numéro de la première ligne, puis cliquez sur supprimer ou clic droit de votre souris et sélectionnez supprimer.

Comme vous pouvez le constater, Le numéro de la ligne est resté à 1, mais le contenu de toute la ligne a été supprimé, ce qui a fait remonter l’ensemble des lignes de la feuille d’un cran.

On contrôle le nombre de lignes existantes dans ma feuille de calcul, pour cela on se positionne maintenant en A30, puis Ctrl + Majuscule (en bas à gauche de votre clavier) + Flèche directionnelle du bas, ce qui me déplace sur la dernière cellule de ma feuille, comme vous pouvez le constater nous avons toujours le même nombre de lignes (1048576). Pour remonter on se positionne sur la dernière cellule, puis Ctrl + Majuscule (en bas à gauche de votre clavier) + Flèche directionnel du haut.

Un autre exemple :

Je souhaite supprimer les lignes 3, 7, 11 et 25. Un clic gauche sur le numéro de la ligne 3 puis je tiens la touche Ctrl appuyée pour sélectionner les autres lignes, en cliquant du côté gauche de la souris, on supprime comme expliqué précédemment.

Pour finir avec ces suppressions de base.

On sélectionne une plage de cellules par exemple : de la ligne 5, à 25, on se positionne sur le numéro de la ligne 5, un clic gauche en restant appuyé un descend jusqu’à la ligne 25, puis on supprime, (ça fonctionne également dans l’autre sens de 25, à 5).

 

Nous allons prendre quatre cas de figures qui sont :

 

1 – les Suppressions de lignes dans une feuille Excel quand la première cellule de la ligne est vide.

2 – Les Suppressions de lignes dans une Plage définie quand une ou plusieurs cellules dans la plage sont vides.

3 – Les Suppressions de lignes dans un tableau déclaré quand la première cellule de la ligne est vide.

4 – Les Suppressions de toutes les lignes dans un tableau déclaré quand dans toute la plage, plusieurs cellules sont vides.

 

Feuille « Exemple, A. »

 Suppressions de lignes dans une feuille Excel quand la première cellule de la ligne est vide.

Vous voyez le tableau qui n’est pas déclaré en tant que tel, quand vous cliquez à l’intérieur de la plage vous ne voyez pas dans le Ruban, Création de tableau.

Dans ce cas on sélectionne la colonne A avec un clic gauche sur, A.

Dans le Bloc Edition un clic gauche sur Rechercher et sélectionner pour ouvrir le menu, puis choisissez Sélectionner des cellules…

Cochez Cellules vides puis validez par OK.

Ctrl+- (signe moins) pour supprimer la ligne, sélectionnez Ligne entière puis validez par OK.

 

 

Feuille « Exemple, B. »

 Suppressions de lignes dans une Plage définie quand une ou plusieurs cellules dans la plage sont vides.

Vous voyez 2 tableaux qui ne sont pas déclarés en tant que tel, quand vous cliquez à l’intérieur de la plage vous ne voyez pas dans le Ruban, Création de tableau.

Dans ce cas on sélectionne les colonnes A, à, G avec un clic gauche appuyé en allant de A, vers, G ou de G, vers, A.

Dans le Bloc Edition un clic gauche sur Rechercher et sélectionner pour ouvrir le menu puis choisissez Sélectionner des cellules…

Cochez Cellules vides puis validez par OK

Raccourci Clavier F5, Puis sélectionnez cellules.

 

Ctrl+- (signe moins) pour supprimer la ou les ligne(s).

 

Le problème dans ce cas, c’est que vous ne pouvez pas supprimer des lignes sans impacter l’autre tableau, nous allons voir comment y remédier dans l’exemple suivant.

 

 

 

Feuille « Exemple, C. »

 

  1. Suppressions de lignes dans une feuille Excel quand la première cellule de la ligne est vide.

Vous voyez le tableau de gauche qui est déclaré en tant que tel, quand vous cliquez à l’intérieur de la plage vous voyez dans le Ruban, Création de tableau.

En cliquant sur Création de tableau vous pouvez voir son Nom en haut à gauche dans le ruban.

Dans ce cas on sélectionne la colonne, A avec un clic gauche sur, A.

Dans le Bloc Edition de l’onglet Accueil du Ruban un clic gauche sur Rechercher et sélectionner pour ouvrir le menu puis choisissez Sélectionner des cellules…

 

Cochez Cellules vides puis validez par OK

 

Ctrl+- (signe moins) pour supprimer la ou les ligne.

 

 

  1. Suppressions de toutes les lignes dans un tableau déclaré quand dans toute la plage, plusieurs cellules sont vides.

Vous voyez le tableau de gauche qui est déclaré en tant que tel, quand vous cliquez à l’intérieur de la plage et vous voyez dans le Ruban, Création de tableau.

En cliquant sur Création de tableau vous pouvez voir son Nom en haut à gauche.

En mode tableau, la suppression de lignes ne peut être faite qu’une seule fois, sur une seule colonne au choix. Dès la deuxième tentative, la fonction de suppression est grisée, il n’est donc pas possible de procéder de cette façon.

Nous allons procéder en deux étapes :

Première étape.

Je vous conseille de commencer par la colonne qui a le plus de cellules vides car, dans ce cas on ne peut pas sélectionner l’ensemble de la plage, on doit donc supprimer les lignes d’une seule colonne, celle de votre choix.

Dans le Bloc Edition de l’onglet Accueil du Ruban, un clic gauche sur Rechercher et, sélectionner pour ouvrir le menu, puis choisissez Sélectionner des cellules.

Raccourci clavier F5 puis sélectionnez cellules

 

Cochez Cellules vides puis validez par OK.

 

 

 

 

 

Une fois que les cellules vides sont sélectionnées nous ouvrons la fenêtre Supprimer et sélectionner, Supprimer des lignes de tableau.

 

Deuxième étape.

Pour continuer à supprimer des lignes qui contiennent de cellules vides, nous sélectionnons la plage entière du tableau, puis nous allons dans le Bloc Edition de l’onglet Accueil du Ruban, un clic gauche sur Rechercher et sélectionner pour ouvrir le menu, puis choisissez Sélectionner des cellules.

Raccourci clavier F5 puis sélectionnez cellules.

Une fois que les cellules vides sont sélectionnées nous ouvrons la fenêtre Supprimer et sélectionner, Supprimer des lignes de tableau.

Bravo ! Votre tableau vient d’être nettoyé avec succès.

 

Comment convertir de Chiffres en Lettres ?

  • Coller le fichier Excel NBLettre sur le Bureau. Cliquez ici !
  • Ouvrir le Fichier Excel dans lequel vous souhaitez faire la conversion.
  • Aller dans Fichier puis Options choisir Complément puis Compléments Excel.
  • Un choix est proposé si vous n’avez pas NBLettre alors cliquez sur parcourir puis sélectionnez le Fichier que vous avez collé sur le Bureau vous le verrez apparaître dans vos options puis Ok pour valider.
  • Félicitations ! Vous avez ajouté cette fonction qui n’est pas disponible par défaut.
  • Dans la cellule où vous voulez le résultat choisissez cette Fonction =ConvNumberLetter(Sélectionnez la cellule à convertir;1;1) puis point-virgule 1 pour la devise puis point-virgule 1 pour la langue.
  • Vous avez maintenant installé cette option qui sera disponible pour tous vos fichiers.

Comment créer une liste déroulante avec filtre ?

  • 1  Chercher les Lettres dans un mot.
=SIERREUR(CHERCHE($H$5;A2);0)
  • 2  Chercher le Nombre d’occurrences trouvées.
=SI(C2=0; » »;NB.SI($C$2:C2;1))
  • 3  Afficher les valeurs trouvées.
=SIERREUR(INDEX(A:A;EQUIV(LIGNE(D1);D:D;0)); » »)
  • 4  Définir un Nom pour cette Plage avec la formule dans le bas de la fenêtre du « Gestionnaire de noms » en nommant le nom de la Feuille.
=DECALER(‘Liste Déroulante’!$E$3;;;NB.SI(‘Liste Déroulante’!$E:$E; »?* »)-1)
En Photo le Mode Opératoire pour la Création d’une Fenêtre Déroulante avec Filtre Automatique avec Recherche par Lettres ou Caractères.

Comment Créer une Barre de Recherche ?

Dans la colonne C

On compte les Lignes non Vides à partir de A5

Pour cela on Utilise la Fonction =LIGNES()

=LIGNES($A$5:A5)

____________________________

On retrouve les N° de Lignes correspondants à ce qu’on Recherche dans $G$3 pour l’exemple les Lettres AR sont retrouvées dans la colonne A en partant de A5 puis on reporte le N° de ligne Dans la colonne D là où cette Formule est collée.

On Utilise les Fonctions Concaténées : 

=SI()

=ESTNUM()

=CHERCHE()

=SI(ESTNUM(CHERCHE($G$3;A5));C5; » »)

 

____________________________

Avec cette Formule on regroupe dans la colonne E les Valeurs trouvées dans la Colonne D.

On utilise les Fonctions Concaténées :

=SIERREUR()

=PETITE.VALEUR()

=SIERREUR(PETITE.VALEUR($D$5:$D$201;C5); » »)

____________________________

Dans la Colonne G par la Fonction =INDEX on va chercher la correspondance de la colonne E dans la Colonne A « Pays »

Autant de N° trouvés dans la Colonne E autant de Noms de Pays trouvés dans la Colonne A

Pour cela on utilise les Fonctions Concaténées :

=SIERREUR()

=INDEX()

=SIERREUR(INDEX($A$5:$A$201;E5;1); » »)

 

____________________________

Par une =RECHERCHEV() on récupère le Nom de la Capitale associée au nom du Pays trouvé.

On Utilise les Fonctions concaténées :

=SIERREUR()

=RECHERCHEV()

=SIERREUR(RECHERCHEV(G5;TPaysCapitale2;2;0); » »)

 

 

Comment créer une Liste Déroulante avec Saisie Semi Automatique ?

Pour Votre menu déroulant vous Partez du Liste de choix
1 – Vous sélectionnez la première cellule Que Vous Nommerez à votre convenance pour l’exemple c’est p_pays puis Valider par OK
image.png
____________________________
Puis vous sélectionnez la colonne complète en cliquant sur A que vous nommer à votre convenance pour l’exemple c’est l_pays puis Valider par OK.
image.png
____________________________
Vous sélectionnez la plage ou la liste déroulante doit être activée puis dans données; Validation des Données choisissez Liste
puis dans source collez la formule suivante.
=SI(A2<> » »;DECALER(f_pays;EQUIV(A2& »* »;f_pays;0)-1;;NB.SI(f_pays;A2& »* »);1);f_pays)
Cela fonctionne très bien.
Remarque : J’ai donnais le nom pays car ma sélection concerne les pays mais modifiez à votre convenance.
image.png
____________________________
C’est prêt il vous suffit de taper une première lettre puis cliquez sur la flèche et vous verrez une liste qui correspond à la lettre vous pouvez affiner votre recherche en ajoutant 1 ou plusieurs lettres.
image.png